随着 WordPress 的不断更新,官方早在3.7的版本中就添加了 WordPress 自动更新的功能,考虑到很多朋友在使用很早以前的 WordPress主题和插件,也许会造成后台的错误提示或者前台网页出错,所以木屋这里分享一下禁用 WordPress 自动更新的几种方法。

第一种方法代码如下:

[cce_php]
// 禁用 WordPress 自动更新
define( 'WP_AUTO_UPDATE_CORE', false );
[/cce_php]

你没看错,就这么一段简单的代码,只要把这段code加到 wp-config.php 文件中即可禁用WordPress的自动更新。

第二种:如果你打算永远不升级你的 WordPress,那么我建议你可以在你的服务器中把WordPress文件夹给设置“不可写”权限,这样不仅可以禁用自动更新,还可以防止WordPress系统文件被恶意PHP代码感染。(至于这么设置文件夹权限,我推荐大家 Google 一下。)

参与评论

  • @TXisfine游客
    我的博客在SAE,很有必要关闭他
    6年前 (2014-08-08)
    7楼
    回复
  • 木屋站长
    你在SAE,那么你根本就没办法自动更新...SAE没有那个权限
    6年前 (2014-08-25)
    回复
  • @TXisfine游客
    是的,但是看着他提示,心里不爽。。。
    6年前 (2014-08-27)
    回复
  • 木屋站长
    好吧
    6年前 (2014-08-28)
    回复
  • @TXisfine游客
    嘿嘿!~
    6年前 (2014-08-30)
    回复
  • aisin游客
    我博客有好多个, 很多有时忘了去手动更新, 这时自动更新就能起到不错的作用
    6年前 (2014-03-23)
    6楼
    回复
  • 木屋站长
    不过我个人偏向于手动更新
    6年前 (2014-03-24)
    回复
  • 木屋站长
    确实
    6年前 (2014-03-23)
    回复
  • zww.me游客
    我的好像不会自动更新,奇怪,哈
    6年前 (2014-03-19)
    5楼
    回复
  • W3Cshare游客
    我的也是
    6年前 (2014-03-20)
    回复
  • 木屋站长
    哈哈~
    6年前 (2014-03-20)
    回复
  • 木屋站长
    vps文件权限、wp-config.php设置,都是可以影响的。我个人感觉这个自动更新就是鸡肋
    6年前 (2014-03-19)
    回复
  • zww.me游客
    我的还是提示我升级,然后我点了升级才能升级。
    6年前 (2014-03-19)
    回复
  • cy游客
    同事还可以禁用插件更新~加另外一行代码。
    6年前 (2014-03-19)
    4楼
    回复
  • 木屋站长
    有类似很多的,我到时候整理一下
    6年前 (2014-03-19)
    回复
  • 这牛儿!游客
    还用着3.5的。
    6年前 (2014-03-18)
    3楼
    回复
  • 木屋站长
    不错~
    6年前 (2014-03-18)
    回复
  • 我爱集分宝游客
    一直都是自动更新的路过
    6年前 (2014-03-16)
    2楼
    回复
  • 6年前 (2014-03-16)
    回复
  • 木屋站长
    我都已经忘记我第一个接触到的是什么版本了
    6年前 (2014-03-15)
    回复